問い合わせ

ExcelでCSVを開く際、住所の番地が日付に変わってしまう問題への対応方法

友だちの情報をCSVファイルにエクスポートしてから編集するときに、番地欄が日付に変わるなど、数字の形式が自動で変わることがあります。

番地欄が日付になった状態でCSVファイルを保存してインポートした場合、番地欄の値が誤った内容で上書きされます。

今回の例では、CSVファイルをExcelで編集するときに数字の形式が変わらないようにする方法を紹介します。

ご利用のExcelのバージョンにより画面が若干異なります。 ご利用中のバージョンが本記事と異なる場合、「Excel CSV 文字化け」のキーワードでGoogle検索すると解説記事があります。 弊社の記事ではありませんが、あわせてご確認ください。

手順

  1. 新規のExcelファイル(空白のブック)を開きます。

  2. CSVファイルを選択します。 「データ」>「データの取得」>「ファイルから」>「テキストまたはCSVから」をクリックします。 ファイルの選択画面が表示されるので、編集したいファイルを選択してください。

  3. 読み込み形式を指定します。 読み込み内容を確認して【読み込み】をクリックします。 ※Excelのバージョンによりオプションが異なります。

「テキスト ファイル ウィザード」画面が開く場合

※「テキスト ファイル ウィザード」画面のオプションはExcelのバージョンによって異なります。 ※ご利用中のバージョンと事例が異なる場合、「Excel CSV 文字化け」のキーワードでGoogle検索すると解説記事があります。弊社の記事ではありませんが、あわせてご参考になさってください。

  1. 「テキスト ファイル ウィザード-1/3」画面で、【次へ】をクリックし、「テキスト ファイル ウィザード-2/3」画面に移動します。 「区切り文字」で「コンマ」にチェックを入れます。 ※元々チェックが入っている場合はそのままで構いません。
  2. 「テキスト ファイル ウィザード-3/3」画面に移動し、数字の形式が変化してしまう列をプレビューで選択します。列のデータ形式で、「文字列」を選択します。
  3. 【完了】をクリックしてデータを反映させます。 指定した列は文字化けせずに元々のデータが反映されます。
    この場合、下記の書式設定の手順は不要となります。
  1. セルの書式設定を行います。 自動変換されてしまう列を選択し、右クリックから「セルの書式設定」を開きます。

    サンプルファイルではG列
    サンプルファイルではG列

  2. セルの書式を「文字列」に設定します。 【表示形式】> 分類から「文字列」を選択し、【OK】をクリックします。

以上の手順でCSVファイルを開くことで、数字の形式を変えずに編集ができます。 友だちの情報編集などにご活用ください。

関連記事

友だちの情報をCSVエクスポート・インポートする方法

Lステップ公式サイト - 初期費用なしで月額0円から Zoom個別相談 - 設定から活用方法まで Lステップ公式サイト - 初期費用なしで月額0円から